Tags:
create new tag
, view all tags

Bug: ExclamationMarkInsideAsterisksDoesNotWork

Using exclamation mark to bypass automatic WikiWord linking inside bold text does not work. The old version with <nop> works, however.

Test case

This does not work:

*!WikiWord*

(Effect: Normal: WikiWord Bold: !WikiWord)

while this works:

*<nop>WikiWord*

(Effect: Normal: WikiWord Bold: WikiWord)

I guess there is a bug in the render engine.

Environment

TWiki version: TWikiRelease02Sep2004
TWiki plugins: DefaultPlugin, EmptyPlugin, InterwikiPlugin
Server OS: Linux
Web server: Apache 2
Perl version: 5.8.x
Client OS: Linux
Web Browser: Firefox

-- GuidoOstkamp - 13 Apr 2005

Impact and Available Solutions

Follow up

Fix record

Discussion

There's no bug - a bumpy-case word in * is not a wikiword - from the definition of wikiwords in TextFormattingRules:

WikiWord Links: CapitalizedWordsStuckTogether (or WikiWords) will produce a link automatically if preceded by whitespace or parenthesis.

This point is under review elsewhere; several people want the definition of wikiwords extended to include WikiWords and WikiWords.

-- CrawfordCurrie - 14 Apr 2005

Edit | Attach | Watch | Print version | History: r2 < r1 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r2 - 2005-04-14 - CrawfordCurrie
 
  • Learn about TWiki  
  • Download TWiki
This site is powered by the TWiki collaboration platform Powered by Perl Hosted by OICcam.com Ideas, requests, problems regarding TWiki? Send feedback. Ask community in the support forum.
Copyright © 1999-2017 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.