Tags:
create new tag
, view all tags

Problems running XpTrackerPlugin

This is the place to discuss problems installing and running XpTrackerPlugin


Hi, I'm relatively new to Twiki etc, but I'm having real trouble trying to get certain XpTrackerPlugin (Version 2.0) functions working on Windows 2000. I've installed the plugin successfully and set up a project, team, iteration and story easily enough. But when I come to display either my project or the demo, the perl code seems to disappear into lala land and my browser hangs. I've found that the %XPSHOWPROJECTITERATIONS{MyProj}% and %XPSHOWPROJECTSTORIES{MyProj}% functions don't return properly.

This really only seems to be a problem wI've got > 1 story under a project. A single story works ok.

Any ideas? (I'm not sure if this is the correct forum for this or whether I should raise a bug)

-- SteveNash - 23 Oct 2002

I am in the same boat, Steve, however it happens with us even with V1.0. I tried to diagnose this forever with not much luck -- sometimes it seems that errors in the format of a story cause the problem, yet sometimes it seems that the number of stories is too high (we have about 30 and the system just got stuck again).

Any advise anyone? Thanks.

-- BorisKhattatov - 23 Oct 2002

Never rain but it poors. We're also trying to install. In our case, we get the Projects list (and can add it to any page) but when you create a new page nothing is included in the project edit; its just a blank page. And after saving, the project does not show up in the projects list. We're real Twiki amatuers here so perhaps we're missing something obvious in the setup..[Followup] Do you have to have a dedicated web called "Tracking"? Or (as I had assumed) does the page just mean that you can put the projects list at any web? [Update; Martin's suggestions worked. -Miles] [New Update 125 Oct 2002: Well, not quite, see ChipUpsal msg below.]

-- MilesParker - 23 Oct 2002

Wow. Ok, I got Steve's data and cannot reproduce his problem on my system. I wonder if it is OS-related? I have an UNIX/Apache server. I do not have easy access to a Win2000 server to test on, so it's going to be hard to debug, although Steve provided some useful diagnostics.

Does anyone have the plugin working ok with Win2000? Anyone Perl-savvy enough to eyeball the code for functionality that is likely to be nonportable? Comment by ThomasWeigert: I am running on W2K without problems, but see feedback in XpTrackerPluginRequests.

Boris: what server are you running? When you say you have 30 stories, is that in one iteration, or for the whole project? We have over 100 stories for one project, so I don't think the number is the problem. Are you having exactly the same problems as Steve - the same functions fail?

Miles: did you put all the files provided in the data/Tracking directory into your own web, including the template files, eg ProjectTemplate.txt? ProjectTemplate is the file it should be picking up to create the new project page. It should work if you put the files into an existing web, but did you try putting it into a separate web as well? Note that the Project will not show up in the projects list until you fill it in by creating one or more iterations and one or more stories. The plugin starts parsing with the Story pages to build up the tables, so if there are no stories entered you will not see anything in the tables.

Are you all running with the latest official TWiki release, 01Dec2001? That is the only one I have worked with.

-- MartinWatt - 24 Oct 2002

Martin, we are running Apache + WinXP. We have about 30 stories in 2 iterations. Everything worked just fine until now. It still does, but whenever I add a story, %XPSHOWSTORIES% seems to hang forever, that is the browser just keeps on waiting. If you can point me to any aspects you persieve as problematic it would be great. Say, one or more stories have subtle formatting "irregularies", like a non-ascii character or beginning/starting/duration date inconsistensies. Thanks!

-- BorisKhattatov - 24 Oct 2002

Problems with a new installation: We are having the following problem: I create a new project. Template comes up fine. Save changes. Create a team. Save Changes. Create Iteration…Save Changes. Add Story and Save Changes. I can go to the Project, Team, Iteration and Story pages. However the Iteration page I cannot see my stories. When I go the Team Page I cannot see the Iteration. When I go to the Projects page I cannot see my project. We are using: TWiki version 01 Dec 2001. I double checked the permissions on all files and they seem correct with apache owing all files. I am also having file locking problems. After creating a page I cannot edit the included tables because Twiki complains the file is locked. This occurs until it delete the .locked file.

-- ChipUpsal - 25 Oct 2002

Chip - A quick check - did you name the story pages so their title ends with the string "Story"? That is the only way the plugin identifies stories.

-- MartinWatt - 25 Oct 2002

Martin, [Chip and I are working on this together] yep, we ended the new stories with Story, and I presume that Iterations are supposed to be of the pattern It*. Could it cause a problem if we already had WikiWords ending with "Story"?

-- MilesParker

Miles. I can't check right now, but it could indeed be that having other pages ending in "Story" will be a problem. The plugin will parse these pages looking for certain text strings, and the code may not be smart enough to handle cases where those strings are not found. (BTW the iteration pages can have any name, they don't have to start with It*)

-- MartinWatt - 25 Oct 200

I recreated ChipUpsal's experiment, but did not have the same problem. After I created Project, Iteration, and Story, I was able to see all the references. Installation is as described here (under ThomasWeigert). Having other topics (i.e., non-story topics) ending in "Story" is indeed a problem as discussed in XpTrackerPluginRequests...

-- ThomasWeigert - 26 Oct 2002

The "Developer" field is mandatory when defining tasks. If blank, then stats aren't computed (correctly/completely).

There are still places in XpTrackerPlugin.pm (using the 3.1 beta from Sourceforge) popping up messages in Apache's error_log, e.g.,

  • view: Use of uninitialized value in numeric eq (==) at ../lib/TWiki/Plugins/XpTrackerPlugin.pm line 1335.
  • view: Use of uninitialized value in concatenation (.) or string at ../lib/TWiki/Plugins/XpTrackerPlugin.pm line 1244.

I noticed iterations weren't being sorted by date, and it seems tied to this code:

   $iterText =~ /\<!--START *(.*?) *--\>/s;
and these messages:
  • view: Argument "PracticumProject" isn't numeric in numeric comparison (<=>) at ../lib/TWiki/Plugins/XpTrackerPlugin.pm line 1040.
  • view: Argument "PracticumProject" isn't numeric in numeric comparison (<=>) at ../lib/TWiki/Plugins/XpTrackerPlugin.pm line 1121.

-- AnthonPang - 01 Jan 2003

  • New topics based on templates (Project, Team, Iteration etc.) don't get their parent set.

I'm admin'ing a Dec2001-TWiki, XpTracker3. Problem: The topics not having a parent cause the upper navigation bar to screw up, where users wanted to have the parent instead of WebHome. Alas, TWiki returns a paragraph-markup for META{...} if there's no parent. No Solution: Adding nops or nbsp to the view template or anywhere else (a suggested solutions for similar problems elsewhere) was of no use. Question: is this a problem of the plugin/its templates, or of TWiki or its templates?

-- PatrickHansmeier - 21 Feb 2003

Patrick - this is a problem with Dec2001 TWiki. See NoParentCreatesAParagraph for a patch that fixes it.

But I'm glad you raised this, as the plugin could actually make use of that PARENT field to store dependencies. Currently it manually adds an additional field to each child page with the parent name, eg a story page has it's iteration page added on creation. If it used the PARENT tag instead the dependency would still be recorded, and there would be less clutter on the page. It would allow you to see the full project/team/iteration/story path at the top of each page and traverse it quickly. Hmm, I like it. One disadvantage may be that it is not so obvious how to change a parent. I'll add it to XpTrackerPluginRequests for consideration.

-- MartinWatt - 22 Feb 2003

I have the same hanging (waiting forewer to generate html page) problem with this plugin on Windows 2000 SP3. We have one TWiki setup on Linux and another (in different office) on Windows (same TWiki version, same XPTracking plugin source). Linux one works with no problems. On Windows it works for few minutes and then hangs. I have installed latest version 3.100 It started to work, but again after few clicks hanged. In error log on Linux we have all these warnings about uninitialize variables, on Windows they printed as errors. Looks like this plugin is not working on Windows.

-- LeanidNazdrynau - 26 Feb 2003

Leanid - If you are seeing the hang on Windows only, could I ask you to first try the 3.0 version of the plugin? Some caching code was added to 3.1 and I didn't find anyone who could test this on Windows before I released it. It may be that it just doesn't work on that platform. Unfortunately I don't have access to a Windows server to test the plugin on. Can you also post the errors you are getting? Do you get a particular error just before it hangs? What web server are you using, Apache or IIS or other?

-- MartinWatt - 26 Feb 2003

We tried with both versions. First 3.0 then 3.1. Funny thing it works for few times (clicks) than hangs. With 3.0 I could not open Iteration pages, but project, teams and story were fine. With 3.1 only story page works Project/Team/Iteration hangs. I did not have direct access to Windows box, but I got log file. Nothing suspicisos only uninitialize variable errors. Maybe windows perl more sensible to this one. I will attache zip file with logs for version 3.0 I have added two function so check line number in my .pm file.

I noticed one thing. I could not open page even after I removed XpTracking tag. I had only one tag %TOPIC%. After I removed this last tag I was able to open Iteration page (with no information of cause). May be it's permision, but I did not see in log anything about can not write or something. Like I said I did not have full access to this box and looks like we give up and will try to setup TWiki on different Unix box.

Can you tell on what platforms XpTracking works for sure. We know it's fine on Linux, but another office does not have Linux only Windows and Unix. What Unix platform you can recomend Solaris/HP/AIX ?

-- LeanidNazdrynau - 27 Feb 2003

I know for sure it works on Linux and IRIX. Anyone else had success with any other platforms? Leanid - are you using Apache or IIS?

-- MartinWatt - 27 Feb 2003

Apache.

-- LeanidNazdrynau - 03 Mar 2003

A few days ago I enabled mod perl on our Apache server to see if there was an improvement in performance for twiki. The side effect of this was the XpTrackerPlugin no longer works correctly. Tracking is performed on several webs and everything works fine so long as mod perl is not used. With mod perl activated going to First.ProjectTopic displays correctly follow this by going to Second.ProjectTopic (another web) and the project table will include projects from the First.ProjectTopic. This errant information eventually ends up in the .xpcache which will continue to grow over time (eventually slowing twiki to a crawl which is what brought the problem to my attention).

I'm wondering if anyone else is using mod perl with XpTrackerPlugin and/or experienced similar problems, have a solution?

I'm using XpTrackerPlugin 3.1 on the 01 Dec 2001 TWiki.

-- RobertWoodcock - 02 Apr 2003

Hi Robert. I too would be interested to hear any input on getting XpTrackerPlugin working with mod_perl. In the next couple of weeks we will migrate our TWiki to a new Linux box, and as part of that will try to enable mod_perl, so we will attempt to address any problems that exist. However I don't have a lot of experience (well none actually) in tracking down problems in code used with mod_perl, so if anyone has any suggestions for the type of code that will likely cause problems when using mod_perl, I'd be interested to hear.

-- MartinWatt - 02 Apr 2003

Martin. First, thanks for this nice plugin. Second, I'm attaching a patch for XpTrackerPlugin.pm that works under mod_perl. Here's my setup:

  • Apache/1.3.19 (Unix) (Red-Hat/Linux) mod_ssl/2.8.1 OpenSSL/0.9.6 DAV/1.0.2 PHP/4.0.4pl1 mod_perl/1.24_01

  • TWiki 20030201 (+ a couple of cgi patches recommended for use with KoalaSkin)

I'm not making any gaurantees that the patch is "correct" but it runs under mod_perl (and use strict) without error. I've tested adding stories and iterations to existing projects and haven't had any problems. Note that I use separate webs for each project.

-- DougDouglass - 21 Apr 2003

Doug - thanks greatly for the patch. Do you notice a significant performance improvement when using mod_perl - both for TWiki in general and for this plugin in particular?

-- MartinWatt - 22 Apr 2003

I knew that would be your first question Martin ;). I do notice a significant speed increase in webs where I've enabled XpTrackerPlugin, and in TWiki in general, though I have no hard numbers.

_Note
I am having some issues with @INC and a difference between the execution architecture of mod_perl versus /usr/bin/perl. This isn't a problem with XpTrackerPlugin at all, but it is a significant issue of configuration/coordination that I hadn't considered. The problem I came across occurs with the LdapPlugin, which makes use of architecture dependent Perl modules. _

-- DougDouglass - 22 Apr 2003

Well, Martin, I'm now experiencing the cross-web corruption that RobertWoodcock observed above. I'll try and document some steps to reproduce, but right now I need to track my project smile

Note that I switched from the Apache::Registry handler to Apache::PerlRun as another way of migrating from cgi to mod_perl. My thinking being that with Apache::PerlRun I gain the advantage of no startup overhead for each script request, but, by not caching the compiled results, I would mitigate global data corruption in scripts/modules that aren't yet written for mod_perl. This doesn't appear to be the case.

Also, I made some small edits to my note above

-- DougDouglass - 28 Apr 2003

Martin, Robert, I've fixed the cross-web corruption problem, in a way, and have everything working under the Apache::Registry handler. The main problem was the use of global data for the cached information.

The fix relies on enabling XpTrackerPlugin in individual webs and disabling in it via TWikiPreferences.

Each time a request is made to a web, Plugin::registerPlugin is called for each plugin enabled for that web, which in turn calls the initPlugin method of each plugin module. By undef'ing the cached data (%cachedProjectTeams, etc) and calling xpCacheRead in the initPlugin method, data from any other web is purged.

I've done some minor testing -- create a new project, new team, new iteration, new story, switching between XptrackerPlugin enabled webs -- and have no corruption issues.

I can produce another patch, but it will be inclusive of the current patch attached below.

-- DougDouglass - 29 Apr 2003

Doug - I've just got back from being away on business and am delighted to see someone has had a chance to take a look at the problem - Thankyou. I'd appreciate it if you could produce another patch. I haven't tried the existing one yet so it won't matter if it is inclusive of the current one.

Note that the XpTrackerPluginDev page has reported the same problem now so I've added comment that your patch is here and they might light to try it.

-- RobertWoodcock - 09 May 2003

Just upgraded from v3 to v3.1. Plugin seems not working for Windows Twiki. (XPtracker was working fine on v3.0 but not on v3.1, ie %XPSHOWALLPROJECTS% do nothing at all)

-- HengMengDIY - 09 May 2003

Robert, I attached a new version of the patch (mod_perl and corruption fix). I've actually been doing a lot of XpTracker work this past week and the only problem I've seen is an occasional blank table row when displaying iterations and iteration details. This is intermittent (and I've been busy smile ) so I haven't tracked down the cause, though it I believe it's a "code-only" issue as the .xpcache files look fine.

thanks for cross-commenting under XpTrackerPluginDev, I need to keep up on that topic.

-- DougDouglass - 10 May 2003

Doug, Thanks for the patch. All installed and seems to work fine with mod perl. Much faster! Haven't seen the "occasional blank line" you mentioned yet but will let you know if I find a pattern if/when it occurs. Thanks for the effort in fixing this.

-- RobertWoodcock - 15 May 2003

I'm trying to setup my first project after having installed all necessary plugins. I've got as far as creating my first "story" page. Problem is that when I try to click on "Edit Table" (in order to add a new task) then I get told that the page is currently locked by TWikiGuest - and that I must wait up to one hour etc. Having read the docs then I thought this shouldn't happen because I Set RELEASEEDITLOCKCHECKBOX = checked in TWikiPreferences.

Anybody got an idea how I can fix this?

-- SimonHardyFrancis - 16 May 2003

I was able to use the XpTrackerPlugin version 3.0 together with a standard TWiki (version 01 Dec 2001). However, in order to use the XpTrackerPlugin with Apache's mod_perl the patch to the XpTrackerPlugin version 3.1 attached to this topic is required. I was unable to use either the original XpTrackerPlugin version 3.1 or the patch (version 3.1.0.1) because HTTP::Date was not installed. Installing the file Date.pm in ~twiki/lib/HTTP/Date.pm resolved the problem.

-- JensKaemmerer - 01 Jul 2003

I'm trying to debug getting XpTrackerPlugin going on Twiki 01 Feb 2003. I just noticed I think I need HTTP::Date as noted above. Maybe that will solve my problem.

-- ThomasMatelich - 21 Aug 2003

Had this same problem (Win 2000, Apache, cygwin, twiki Feb 2003). Symptom: Install the pluging and nothing happens. the plugin does not even register. There are pleny of hints that installing HTTP::Date is usefull. In fact this does fix the problem.

You find the evidence in TWikiDebugging with the suggested method for Debugging Plugins. This:

$ cd /twiki
$ perl -Ilib -e 'use TWiki; use TWiki::Plugins::XpTrackerPlugin;'
tells you the plugin needs HTTP::Date.

Once installed, all is well.

-- BramVanOosterhout - 09 Dec 2003

Sometimes I notice that the .xpcache file is not being updated properly. Looking at the code I found that the cache ask for the date of the DIRECTORY the cache is in. If it's changed then the cache is staled. This just don't work in windows. So solve this I hacked the Plugin.pm, and Store.pm code to add a new handler (afterSaveHandler), and update the cache after each save. It slows a bit the saving process, but guarantee that the cache is in sync.

I uploaded a patch to XpTrackerPluginDev with this fix and several other modifications.

-- RafaelAlvarez - 14 Jan 2004

Rafael - why doesn't the directory date method work on Windows? And how much does your patch slow down the saving process? Maybe we could make your fix Windows-specific as it would be a pity to slow down all platforms.

-- MartinWatt - 15 Jan 2004

To be true, I don't have idea why the directory method is not working. Let me be more specific: It doesn't work on neither my Windows XP box or my Windows 2k box.

Now that I came to think about it, perhaps it was because a modification I did in the caching code. If the cache was stale then in rebuild it and then read it. The cache building process fills the same structure than the readCache sub, so it'll read the cache only if the cache exists and is not stale, otherwise it'll only rebuild it.

As for the slowdown, I haven't test it but my guess is that it's the same as it was when reading a page with a staled cache, perhaps a little better because the cache is not builded and readed.

-- RafaelAlvarez - 15 Jan 2004

I have the "stale cache" problem on my unix box also. I did the same as RafaelAlvarez, and invalidate the cache on every save. I do not notice the slowdown, albeit our system tracks a huge number of stories. Unfortunately, the system is slow when stories are viewed due to it having to traverse the whole data base almost every time. We keep clearing out completed iterations to another web so as to keep performance of the active iterations acceptable.

-- ThomasWeigert - 31 May 2004

FYI the FormQueryPlugin avoids the need for hacking the core by refreshing the cache on demand i.e. every time the cache is read it is checked for freshness. Seems to be fast enough.

-- CrawfordCurrie - 31 May 2004

Thomas, how many stories are we talking about? With the last version uploaded in XpTrackerPluginDev we managed to have a total of 1200 stories across iterations without performance problems, the biggest iteration having about 300 stories. One thing we did was to move the XpShowIteration tag from the Iteration page to a separate page.

Speaking of versions, I really should find the time to update both the CVS and the release frown

-- RafaelAlvarez - 31 May 2004

I just downloaded the 3.2 version and I've had quite a few problems installing it.

  1. The path information in the zip file is not the same as the path information listed on the plugin page. All the files were in a directory "XpTrackerPlugin". I assumed that I needed to move the files to the locations of the documentation.
  2. Once I got all of the files moved around I tried to use the ManagingWebs "Adding a New Web" form to create my first XP Tracking web (I know this diverges from the directions, but it seems a reasonable way to create a new web, especially since I don't plan to publicise the login and password to the other users so they can telnet into the host and copy files). This produces several errors that apparently stem from the fact that no ,v files were included in the distribution. I opened and saved each file in the Template web in order to fix this problem.
  3. It also seems that instead of naming the template web "Tracking" something like "_XpTracking" would be more appropriate as that makes the web an invisible template for use with the "Adding a New Web" tool.

-- JoshuaTharp - 07 Oct 2004

Upon further review... my work arounds did not work. It would be a really nice feature to package this plugin such that I could create a new XP Tracking web from the web creation tool.

Ok, I see several messages speaking to two problems.

  1. The project tables are not being populated.
  2. The tables are initially locked and required an "edit anyway" action followed by a cancel in order to be able to edit them.

I'm having both of these problems with an installation on Linux running "This is perl, v5.8.0 built for i386-linux-thread-multi" perl. I do have HTTP::Date installed (as far as I can tell, the library is in the correct position and the "perl -Ilib -e 'use TWiki; use TWiki::Plugins::XpTrackerPlugin;'" did not reveal anything, as it simply returned after printing no messages). I haven't found any documentation yet that solves these problems, but either people are abandoning this plugin or they are finding solutions... Anyone care to post the solution?

No sooner did I hit save and I found some .xpcache comments, deleted the file, and my project information showed up.

-- JoshuaTharp - 07 Oct 2004

OK, I need a little help smile I installed the 01 Sep 2004 TWiki release and XP plugin 3.2; However, none of the variables are working - for example, I just see "%XPSHOWALLTEAMS%" on the main web instead of the form. What can I do to get this working???

Thx!

-- BillSnyder - 30 Oct 2004

Bill, make sure that you have the HTTP::Date installed. This is the most common cause of the problem you're describing.

I haven't tested the plugin with Cairo, but it was working up to the last beta before release. I'll look into it.

-- RafaelAlvarez - 01 Nov 2004

Thanks. HTTP:Data is installed. I ran the quick Perl test above and it returned with no message.

-- BillSnyder - 02 Nov 2004


Hi,

I've just installed the XpTrackerPlugin, it seems to "be there". I use .pl for the scripts extension and have set $scriptSuffix = ".pl" in lib/TWiki.cfg. But when I press the buttons like "Project Stories Status" or "Project Tasks Status" on for instance /twiki/bin/view.pl/Tracking/AudioEvent#sorted_table I get a link to /twiki/bin/view/Tracking/XpProjectStoriesStatus where the .pl is missing after the "view".

This of course means that the application does not run. I'm guessing that the $scriptSuffix is missing in the app section where this status page is called.

Can anyone tell me who can fix this, or if I have to dig for this, how I can get the fix to others ...?

When I look at the related files that was created when the topic was created , namely /twiki/data/Tracking/AudioEvent.txt I can see the following line:

=* <a target="WikiSyntax" onClick="return launchWindow('%WEB%','XpProjectTasksStatus')" 

href="%SCRIPTURLPATH%/view/%WEB%">Project Tasks Status</a>=
where I notice that the word view is not followed by something like
 
%SCRIPTSUFFIX%.
I tried to add that manually, to no avail.

Thanks !! Bart

-- BartLouwagie - 10 Nov 2004

Posted the response in XpTrackerPluginProblemsDev

-- RafaelAlvarez - 10 Nov 2004

I have a problem with renaming an iteration. I went to an Iteration and chose the option to Rename/Move it. The rename/move changed all the data in the logs, but the Iteration name itself as produced by %XPSHOWPROJECTITERATIONS{%TOPIC%}% still shows the old name with the famous ? next to it. I can not manually edit the page to correct it of course, so I do no know where to go to fix this.

-- BartLouwagie - 22 Nov 2004

I stand corrected about the above, the problem "self resolved" after about 20 minutes... I had don refresh many times before posting this issue, but after I then went to edit the Tracking.InitialRollout page to debug it, all was fine afterwards. I don't know what caused this "lag".

-- BartLouwagie - 22 Nov 2004

It happens because the cache of topics and iterations is only refreshed when a topic is edited. So if you move/rename a topic it'll remain in the cache until someone edits some topic.

AFAIK, there is no way to notify a plugin that a topic has been moved/renamed, so sadly things will remain the same until the hook exists.

-- RafaelAlvarez - 22 Nov 2004

Using the 3.2.2 version of the plugin on a W2K/apache/mod_perl installation, after saving a page in a web other than the tracking web, all dynamically expanded content in the tracking web is empty. I changed in Cache.pm line 50

    #original: 
    #} elsif (! $web eq $loadedWeb) {
    #new:
    } elsif (! ($web eq $loadedWeb)) {
And now .xpcache is read correctly when changing the web and the above problem is gone.

-- DanielSiegenthaler - 18 Apr 2005

Thanks smile

-- RafaelAlvarez - 01 May 2005

I have installed the current ( 59.3 K 28 Jan 2005 - 02:01 RafaelAlvarez Current Version of XpTrackerPlugin (v3.2.2)) plugin on my Twiki site. The %XPSHOWALLTEAMS% is being picked up by the scripts correctly and shows the Create New Project form.

I have done the following suggestions from above:

  • $ cd /twiki
    $ perl -Ilib -e 'use TWiki; use TWiki::Plugins::XpTrackerPlugin;'

  • installed HTTP::Date
  • I changed Cache.pm line 50

When I try to create a new project I get the following error:

Software error:

Insecure dependency in open while running with -T switch at /export/home/httpd/twiki/twiki/lib/TWiki/Store.pm line 986.

For help, please send mail to the webmaster (you@example.com), giving this error message and the time and date of the error. 

Searching Twiki for this error yields the following page:

http://twiki.org/cgi-bin/view/Plugins/HeadlinesPluginDev?skin=print.pattern

Running HeadlinesPlugin with Perl 5.8.0 (on RedHat 9) yields Insecure dependency in open while running 
with -T switch at $TWIKIROOT/lib/TWiki/Store.pm line 986.

    * $cacheFilename must be explicitely untainted. I include a patch as attachment.

-- AdrianWeiler - 31 Oct 2004 

Anyone have any idea how to fix this for this Plugin?

Thanks

Graham

Problem with IE...

In release of Feb 06 2006 i had a list of stories and velocities did not show on iteration page in Internet Explorer. Following helped:
    File ShowVelocities.pm line 88 was changed to:
        $list .= "<script src=\"%PUBURLPATH%/%TWIKIWEB%/XpTrackerPlugin/sorttable.js\"></script>\n";

    File ShowIterationTerse.pm line 52 was changed to:
       $list .= "<script src=\"%PUBURLPATH%/%TWIKIWEB%/XpTrackerPlugin/sorttable.js\"></script>\n";

added closing </script> tag in both cases.

-- VasylYarmamedov - 16 Feb 2006

Hi all, I had alot of problems running the Xp Plugin. My Tracking web has some errors. On the left side of the screen, a warning message is shown: "Warning: Can't find topic WebLeftBar ". I cannot find any options to create a new project. Going to the configure page, the Xp Plugin is not even shown in the Plugin Diagnostic, though it is listed under the plugins as enabled. I check a log file called warning200603.txt (which i presumed is the error log) and it only says that it can't find error.pm in @INC.

I am using the virtual machine that came preinstalled with TWiki. Please advise and let me know if other details are needed. Please pardon me for my ignorance, i am very new to Wiki and Twiki and i am basically running TWiki to try it out. Thanks.

-- BenOng - 15 Mar 2006

Tried installing the zip from the XpTrackerPlugin page. Many permission problems. Then, the Webhome page didn't display properly (as above), and data/warnxxx had Can't call method "getPreferencesValue".

Installed from svn (and set permissions) to fix it: http://svn.twiki.org/svn/twiki/trunk/XpTrackerPlugin/

The WebLeftBar is missing. Create Tracking/WebLeftBar and put this in it: %INCLUDE{ "%TWIKIWEB%.WebLeftBar"}% .

I suspect you would be well served if you created the web "Tracking" before installing the plugin.

-- AlanGrover - 24 Mar 2006

I did a manual upgrade of Twiki Dakar from 4.0.0 to 4.0.2. I copied over all my personal info from data and lib. However, I can't get my Tracking web to work, meaning all my old tracking information is not showing up in the upgraded web. Where is this tracking info for each web stored? Second, what needs to be done to tell Xp tracker to "read" this information?

thanks

-- CraigAumann - 08 Apr 2006

Never mind! Figured it out!

-- CraigAumann - 08 Apr 2006

EDITCELLS aren't rendered. I've made some changes that allow it to works in 4.0.2. I don't know if this is the best approach.

TrackingIncorrectStartEndIterationDate

-- ManuelSoto - 07 May 2006

I appear to have the same problem as BenOng. I have tried installing XpTrackerPlugin with the TWiki 4.0 family and the plugin continually fails, citing an error with "getPreferencesValue" on the plugin diagnostics page. I've tried this with 4.0.2, 4.0.1, and 4.0.0 (the topic said the build had been tested with 4.0.0). Does anyone know if there is an up-to-date built version of the plugin that I can install?

-- JoshAllen - 06 Jun 2006

XpTrackerPlugin break down wrong WEB urls TWiki redirect. This is due to sub buildcache who fails while trying to create a cache even if given web does not exist. Just need to cancel cache creation if number of topics in given web is <1:

Plugin version 3.3:line 109 :

sub buildCache {
        my $web = shift;
    _cleanCache();

    my @topics=&TWiki::Func::getTopicList($web);

( $#topics <1 ) && return;
    foreach my $topic (@topics) {

thanks smile

-- PatrickNomblot - 16 Jun 2006

When date fields are empties, tables aren't rendered and display %EDITCELL{}% variable

-- ManuelSoto - 02 Jul 2006

I confirm same problem with %EDITCELL{}% variable, even if dates are filled in. A quick and durty solution : add line

   $_[0] =~ s/%EDITCELL{.*}%//g;
in XpTrackerPlugin --> commonTagsHandler and make sure EditTablePlugin is called before XpTrackerPlugin in TWiki configure.

Hope that this help.

-- PatrickNomblot - 06 Jul 2006

I'm using TWiki 4.0.4 with XpTrackerPlugin version 3.3, and getting some weird errors. When I have it installed and running, Tracker webs will work, as will everything else... except the TWiki web. The TWiki web gives me a text/plain style 500 error.

The Apache error_log reads: Can't call method "maketext" on an undefined value at twiki/lib/TWiki/Access.pm line 174.

When I go back into the configure script and turn XpTracker off, the TWiki web starts working again, but of course, the Tracker webs fail. The trouble is, I need both working, not just one or the other; and I still have no clue why the Tracker would cause the TWiki web to fail.

In case it helps: I'm running under Linux, using Apache 2. TWiki 4.0.4 was installed normally, while XpTrackerPlugin 3.3 was installed by hand using the instructions on its main page.

-- AubreySmith - 24 Jul 2006

That's a very, very weird behavior. I'll look into it as soon as I can.

-- RafaelAlvarez - 25 Jul 2006

Try and see if turning tracking off in this web will help. Normally the plugin generates a cache file in every web, and there may be some file in your TWiki web which confuses it.... just a thought.. (we are running our own branch of this plugin so I cannot really test it)...

-- ThomasWeigert - 26 Jul 2006

I had a struggle with the XPSHOWDEVELOPERTASKSBYITERATION report. Called it in the following way:

%XPSHOWDEVELOPERTASKSBYITERATION{Main.MarkusStuder2, PhaseOneIteration}%

which failed due to the space between the "," and the "PhaseOneIteration", calling it in the following form

%XPSHOWDEVELOPERTASKSBYITERATION{Main.MarkusStuder2,PhaseOneIteration}% 

succeeds. Reason: XpTracker tries to lookup the Iteration-data from the cache with " PhaseOneIteration" as key which fails. It took me quite some time to figure out why XpTracker always returns an empty report. Would be nice if this method-calling is somehow more foolproof.

-- MarkusStuder2 - 27 Sep 2006

I am getting the exact same issue as AubreySmith. Has anyone found a solution to this? It seems wierd.

-- EricHanson - 06 Oct 2006

I am having the same situation as AndreySmith did. TWiki 4.0.5 upgraded from 4.0.4. Registration, TwikiGuest functions doesn't work. Removing .xpcache from web folders doesn't help. I am really really would like to have this working if it is possible. --AndreyBudarevsky

-- AndreyBudarevsky - 05 Dec 2006

Twiki version 4.0.5, Plugin version 19 Dec 2006.

We just installed this, and I'm really looking forward to using it on my new project. I'm having some trouble getting parts of it to work though. Using %XPSHOWALLPROJECTS% produces a header of "All s" and a table with no column headers and one row for each project that says TWiki::Contrib::DBCacheContrib::Map=HASH(0x8eb9140) (with varying hashkeys). It is followed by a header that says "Create new" and a textbox, checkbox, "Add sequence number" and a dropdown without any templates in it. If the Create button is clicked, it produces a page with the right name, but no content. However, if I use %XPCREATETOPIC{"Project" prompt="Enter project name"}%, there is a template in the dropdown and it creates a project page with content. Any ideas?

-- LaurieSpencer - 09 Mar 2007

You're using YetAnotherXpTrackerPlugin, not XpTrackerPlugin smile Make sure that you have installed YetAnotherDBCacheContrib instead of DBCacheContrib, as that is the combination the author of those is using.

Hope this help.

-- RafaelAlvarez - 09 Mar 2007

Ohhh... actually it looks like parts of both were installed. We're trying again and hopefully this time it will work. Thanks for the help!

-- LaurieSpencer - 12 Mar 2007

There is a problem for Users of Firefox 3 related to the use of the javascript sorttable.js at the files, lib/TWiki/Plugins/XpTrackerPlugin/ShowIterationTerse.pm and lib/TWiki/Plugins/XpTrackerPlugin/ShowVelocities.pm., because the tag script is not closed so after opening the script tag this should be immediately closed. If this is not corrected, the HTML is not valid so that the table disapeards.

-- JoseMariaCasanova - 24 Mar 2008

I would have swear this was already fixed...

Until I can get around to publish the fix, you can change the code yourself (look for the comment of VasylYarmamedov on 16-Feb-2006

-- RafaelAlvarez - 24 Mar 2008

reports from the Dev topic To be sorted & filed (and perhaps already solved)

Thanks Richard smile

I have committed the beginning of colours management. I was trying to merge Thomas methods (meant for XpTrackerPlugin ver.2) in ver.3, but I get

Undefined subroutine &TWiki::Plugins::XpTrackerPlugin::xpGetProjectIterations called at ../lib/TWiki/Plugins/XpTrackerPlugin.pm line 1633

Martin, did you take out the method? I will check, but maybe you had a quick answer.

-- AndreaBacchetta - 03 Dec 2002

Topic attachments
I Attachment History Action Size Date Who Comment
Compressed Zip archivezip Xp3.0_error_log.zip r1 manage 12.3 K 2003-02-27 - 14:32 LeanidNazdrynau Error log files for version 3.0 on W2K and Linux
Unknown file formatpatch XpTrackerPlugin-mod_perl.patch r2 r1 manage 12.8 K 2003-05-10 - 00:50 DougDouglass mod_perl and corruption fix patch
Edit | Attach | Watch | Print version | History: r75 < r74 < r73 < r72 < r71 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r75 - 2008-03-24 - RafaelAlvarez
 
  • Learn about TWiki  
  • Download TWiki
This site is powered by the TWiki collaboration platform Powered by Perl Hosted by OICcam.com Ideas, requests, problems regarding TWiki? Send feedback. Ask community in the support forum.
Copyright © 1999-2017 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.