Tags:
create new tag
, view all tags

SID-02207: Browser/Edit google chromium bug? (GPL vers chrome)

Status: Asked Asked TWiki version: 6.0.2 Perl version: v5.10.1
Category: CategoryEditing Server OS: CentOS 6.7 2.6.32-573.22.1.el6.x86_64 Last update: 1 year ago

The TWiki is running 6.0.2 The client browser is Chromium Version 50.0.2661.102 Ubuntu 14.04 (64-bit) While editing Main:TwikiUsers using the wysiwyg standard installed editor (ie: I just clicked edit) when I delete a user from a bulleted topic line and go all the way back and delete the bullet with the "backspace" key and save it, the formatting gets messed up in the following way: Originally in raw view the lines which desgnate each letter look like:

  • A - <a name="A">- - - -</a>
After saving it looks like:
  • A - <a name="A">- - - -</a>
This does not happen if I delete back to the bullet, hit return, then go forward and delete from ahead of the next bullet. The Thunderbird browser does not exhibit this behavior! SO, okay maybe it's just a quirk. BTW I stumbled on the work-around while composing this question. Also, it bizarrely makes the normal view after, look like the raw view before. Anyone want to test, maybe on s different version of chrome?

-- John Huber - 2016-06-06

Discussion and Answer

Holy cow! The before/after lines look the same when viewed on this page. The AFTER in raw view is:

* A (ampersand)lt(semicolon)

but if I type the (ampersand lt semicolon) it looks like THE ORIGINAL raw view. This is so confusing!

-- John Huber - 2016-06-06

Not sure what happened. The WYSIWYG editor exhibits some peculiar behavior, and as you discovered, it is browser specific because the browser native HTML widget is used.

For system pages it is safer to use RAW edit.

-- Peter Thoeny - 2016-06-07

      Change status to:
ALERT! If you answer a question - or someone answered one of your questions - please remember to edit the page and set the status to answered. The status selector is below the edit box.
SupportForm
Status Asked
Title Browser/Edit google chromium bug? (GPL vers chrome)
SupportCategory CategoryEditing
TWiki version 6.0.2
Server OS CentOS 6.7 2.6.32-573.22.1.el6.x86_64
Web server apache 2.2 (httpd-2.2.15-47.sl6.4.x86_64)
Perl version v5.10.1
Browser & version Chromium Version 50.0.2661.102 Ubuntu 14.04 (64-bit)
Edit | Attach | Watch | Print version | History: r2 < r1 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r2 - 2016-06-07 - PeterThoeny
 
  • Learn about TWiki  
  • Download TWiki
This site is powered by the TWiki collaboration platform Powered by Perl Hosted by OICcam.com Ideas, requests, problems regarding TWiki? Send feedback. Ask community in the support forum.
Copyright © 1999-2017 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.