Tags:
create new tag
, view all tags

SID-02209: In NuSkin no webnav and user menu shown, however logged in

Status: Asked Asked TWiki version: 6.0.2 Perl version:
Category: NuSkin Server OS: CentOS Last update: 1 year ago

Hi,

I installed the NuSkin, which worked according to the installation instructions fine so far. I installed also all Packages on which NuSkin relies as mentioned in its documentation. I activated the skin in the sandbox web, which worked just fine.

The only thing, which is not working is, that in the mainmenubar directly below the banner at the right handed side, the "webnav" and the "users" menu is missing however I am logged in. There is also no login/logout link at the upper right edge as shown in the screenshot.

May anybody have a hint for me, what I am missing?

Thanks in advance Martin

-- Martin Wikke - 2016-06-13

Discussion and Answer

Hi, me again,

I hope my question is not to dumb, but I really do not understand what could be the reason for this behaviour. I checked some things in between:

  • java script in browser is turned on. E.g. the bar in pattern skin works normal. Tried it with Chrome and Firefox.
  • I set the Variables NUMENUBAR and NUMENUBARCONTENS to the topics referred on the skin Homepage. The setting is carried out in the Web Preferences topic of my web (not TWiki Preferences)
  • In NUMENUBAR I checked the entry for the menuheaders which are missing, e.g. </td><td><a id="user" title="User Authentication, data and bookmarks" style="display:none;"> ... by changing the display style to display:block e.g. the menu button appears, but there is no submenu rolling out when the mouse is over the menu, even though in NUMENUBARCONTENTS there is a quick menu with items added defined. When I click on the button, nothing happens, which makes sense because no link is defined in NUMENUBAR.
  • I tried the NuSkin on TWiki 6.0.1 (ova distribution) --> same behaviour as explained above
  • My web needs authentication: I tried it using admin user and also other users.

I guess it is a very simple thing that I am missing. The skin was released quite long time ago and nobody seems to have observed this before. Would be glad to get a hint ... Thanks Martin

-- Martin Wikke - 2016-06-15

Indeed that skin from 2008 is very old. I have never used it, so don't know how to help.

-- Peter Thoeny - 2016-06-24

      Change status to:
ALERT! If you answer a question - or someone answered one of your questions - please remember to edit the page and set the status to answered. The status selector is below the edit box.
SupportForm
Status Asked
Title In NuSkin no webnav and user menu shown, however logged in
SupportCategory NuSkin
TWiki version 6.0.2
Server OS CentOS
Web server

Perl version

Browser & version

Edit | Attach | Watch | Print version | History: r3 < r2 < r1 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r3 - 2016-06-24 - PeterThoeny
 
  • Learn about TWiki  
  • Download TWiki
This site is powered by the TWiki collaboration platform Powered by Perl Hosted by OICcam.com Ideas, requests, problems regarding TWiki? Send feedback. Ask community in the support forum.
Copyright © 1999-2017 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.