Tags:
create new tag
, view all tags

SID-02229: WysiwygPlugin/tml2html Retrieval Error

Status: Answered Answered TWiki version: 6.0.2 Perl version: 5.10.1
Category: CategoryEditing Server OS: CentOS 6.7 Last update: 1 hour ago

I have a brand new installation of TWiki. All documented system requirements are satisfied. When I select "Edit" for any page (Main, Sandbox, etc.), I get the following error in the editor:

There was a problem retrieving http://twiki.company.com/do/rest/WysiwygPlugin/tml2html: GENERAL 0

I searched TWiki.org and every related issue points to permissions and/or installing Encode. However, my permissions are set correctly (rwxr-xr-x) and Encode 2.35 is installed and in the path according to the TWiki configure page.

-- Mark Rutz - 2016-07-19

Discussion and Answer

I have no solution, but a hunch: You have a brand new installation of TWiki (good!). Your version of Encode and your Perl version are from 2009. We know that Perl went through a very painful learning curve when implementing unicode in the last decade or so. Recent Perls have Encode in their core, thus avoiding any version mismatch. Unfortunately, the Red Hat based Perl distributions are known to be not recent...

So, if if is possible for you, please get rid of all unicode stuff in TWiki's configuration (or maybe also Apache and Linux configuration) and retry whether the error persists. The combination of JavaScript code in the WYSIWYG editor and Perl code in the plugin is tricky stuff with regard to encoding,

-- Harald Jörg - 2016-07-20

I disabled all foreign languages. {Site}{Locale} = en_US.ISO-8859-1 and {Site}{CharSet} = iso-8859-1. However, I still get the error. I will say that I'm having a problem with TWiki/Apache serving up mixed content. So, this may be part of the problem.

-- Mark Rutz - 2016-07-21

I was able to resolve the issue. In my case, it didn't have anything to do with Encode or Perl. It was caused by mixed content being served up by TWiki/Apache and blocked by my browser (SID-02228). Once I eliminated the mixed content, this issue disappeared.

-- Mark Rutz - 2016-07-22

Mark,

What do you mean by "mixed content being served up by TWiki/Apache"?

-- Paul Finkel - 2017-08-23

mark,

How did you fix it?

-- Paul Finkel - 2017-08-25

      Change status to:
ALERT! If you answer a question - or someone answered one of your questions - please remember to edit the page and set the status to answered. The status selector is below the edit box.
SupportForm
Status Answered
Title WysiwygPlugin/tml2html Retrieval Error
SupportCategory CategoryEditing
TWiki version 6.0.2
Server OS CentOS 6.7
Web server Apache 2.2.15
Perl version 5.10.1
Browser & version Chrome 51.0.2704.106 m
Edit | Attach | Watch | Print version | History: r7 < r6 < r5 < r4 < r3 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r7 - 2017-08-25 - PaulFinkel
 
  • Learn about TWiki  
  • Download TWiki
This site is powered by the TWiki collaboration platform Powered by Perl Hosted by OICcam.com Ideas, requests, problems regarding TWiki? Send feedback. Ask community in the support forum.
Copyright © 1999-2017 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.