Tags:
create new tag
, view all tags

SID-02312: Plugin area in config missing

Status: Answered Answered TWiki version: 6.0.2 Perl version: 5.01 linux
Category: Server OS: Linux 2.6.32-220.el6.x86_64 (x86_64-linux-thread-multi) Last update: 2 months ago

I was running a TWiki 5 site on a GoDaddy legacy server and had 6.0.2 installed on a GoDaddy shared server and the files migrated. The site is a closed wiki I use for my company intranet for proposal writing, timelogs ,etc. I'm able to log in and edit without any difficulty as either myself or as the admin.

The problem is in the configure area.

If I go to /bin/configure instead of it asking for my admin password to gain access, it asks me to set a new password, but below the button doesn't say reset, it says configure. If I then type in my existing password it provides the admin access to a limited or incomplete area of the site configuration, saying password was changed, even when it wasn't. The areas it shows is: environment variables (read only), CGI Setup (read only), and General Path Settings.

What's missing is the area for all the extensions/plugins which I used to access from this location in TWiki 5 and which was where I was able to run updates on them and enable and disable them. None of this is visible, currently.

The screengrab is what I see when I click configure.

If this is a change in 6, let me know how to access that area, please. If this is a failure, I'd appreciate some guidance.

-- Norman Smit - 2017-05-12

Discussion and Answer

First guess: The file lib/LocalSite.cfg is missing and the web server user is not allowed to create it. I thought that the configure screen would warn about this problem later on, but I am not sure.

The message that the password was changed is slightly misleading. The password is not yet saved to disk in this stage, but rather used for the rest of the configure session.

-- Harald Jörg - 2017-05-12

That resolved it, thanks Harald. It needed the cfg line uncommented.

-- Norman Smit - 2017-05-16

-- Norman Smit - 2017-05-16

      Change status to:
ALERT! If you answer a question - or someone answered one of your questions - please remember to edit the page and set the status to answered. The status selector is below the edit box.

  • Screengrab of what is seen after configure is clicked:
    configure.jpg
SupportForm
Status Answered
Title Plugin area in config missing
SupportCategory

TWiki version 6.0.2
Server OS Linux 2.6.32-220.el6.x86_64 (x86_64-linux-thread-multi)
Web server

Perl version 5.01 linux
Browser & version Firefox and Chrome fully up to date versions
Topic attachments
I Attachment History Action Size Date Who Comment
HTMLhtml TWiki_Configuration.html r1 manage 64.4 K 2017-05-12 - 17:09 NormanSmit  
JPEGjpg configure.jpg r1 manage 105.2 K 2017-05-12 - 17:11 NormanSmit Screengrab of what is seen after configure is clicked
Edit | Attach | Watch | Print version | History: r3 < r2 < r1 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r3 - 2017-05-16 - NormanSmit
 
  • Learn about TWiki  
  • Download TWiki
This site is powered by the TWiki collaboration platform Powered by Perl Hosted by OICcam.com Ideas, requests, problems regarding TWiki? Send feedback. Ask community in the support forum.
Copyright © 1999-2017 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.