SID-01339: Installation Error; flush(): couldn't open datastr
| Status: |
Answered |
TWiki version: |
5.1.0 |
Perl version: |
5.x |
| Category: |
CategoryInstallation |
Server OS: |
RedHat Linux 5.0 |
Last update: |
14 years ago |
I have been trying to install Twiki 5.1 on Redhat Linux within Apache server. It appears to be a TWiki problem because the file is created by TWiki. My configure file appears okay. The error is: flush(): couldn't store datastr: store(): couldn't open '/twiki/working/tmp/cgisess_a55ba92ed60acbd69a365e649efeb5ce': Permission denied at /twiki/Lib/Twiki/LoginManage any help would be appreciated. I see that this problem occured with a Windows server per your support database but the issue was never resolved.
--
DavidSteininger - 2011-11-24
Discussion and Answer
Permission issue. Make sure directories
twiki/data,
twiki/pub,
twiki/working and directories & files below are owned by the webserver user (
apache in case of default RedHat).
--
PeterThoeny - 2011-11-24
Okay, thanks for the help. I changed ownership to apache for everything,TWiki directories and everything below it. The permissions are those that came with the downloaded TWiki file. Now I get the error:
Content-type: text/plain
Perl error when reading
LocalSite.cfg:
Please inform the site admin.
BEGIN failed--compilation aborted at /var/www/twiki/lib/TWiki.pm line 528.
Compilation failed in require at /var/www/twiki/bin/view line 41.
BEGIN failed--compilation aborted at /var/www/twiki/bin/view line 41.
Is this a persmission problem?
--
DavidSteininger - 2011-11-26
The
twiki/lib directory also needs to be owned by the webserver user so that configure can create/modify the
twiki/lib/LocalSite.cfg file. Please read the
TWikiInstallationGuide.
--
PeterThoeny - 2011-11-26
Well, I used the Unix command chown recursively as indicated in the
TwikiInstallationGuide so I am not sure why this directory wasn't assigned to the ownership of my apache server. I'll continue to investigate. Thanks for the help.
--
DavidSteininger - 2011-11-27
Found my mistake. I now have 5.1 working and I can now migrate my stuff from 4.1 to it. Thanks
--
DavidSteininger - 2011-11-28
What was the mistake? I'm having the same exact issue despite having, I believe, set all the permissions as instructed.
--
ChrisVanDoren - 2011-12-21
--
ChrisVanDoren - 2011-12-21
Sorry Chris for being late on this. When I was messing around with
LocalSite.cfg I had saved it with an incorrect name.
--
DavidSteininger - 2011-12-31
Closing as answered...
--
PeterThoeny - 2012-01-02
If you answer a question - or someone answered one of your questions - please remember to edit the page and set the status to answered. The status selector is below the edit box.