create new tag
, view all tags


It was working, but suddenly it started returning an error message when saving a topic.

During save of Sandbox.TestSave2 an error was found by the version control system. Please notify your TWiki administrator.

=/usr/bin/ci -m%COMMENT|U% -t-none -w%USERNAME|S% -u %FILENAME|F% of .../Sandbox/TestSave2.txt failed: 1 = 

It looks the same error was reported here, but it was closed without any answer.

There is an error in the apache log, but the time stamp shows it's not related. It says TWiki::Configure::Checker::tempfile redefined at /usr/share/perl/5.8/Exporter.pm line 65.

The automated email notification (WebNotify) shows the difference between two versions (correctly as far as I see), but the history on a page shows only the first save and the rest of revisions are blank. However, if I click the individual revision then it shows the details.

I used the trace option in Sandbox.pm and checked the apache error log. It shows

/usr/bin/ci '-mnone' '-t-none' '-wTeruYanagihashi' '-u' '/home/httpd/twiki/data/Sandbox/TestSave2.txt'

and I tried the command on the console. The file was locked by www-data (CGI user name ) and I re-locked it with root. After that then the command was accepted under root. The file attribute is rw-r--r--. So, it looks like when the command is executed somehow the user name is not recognised as www-data. No mod_perl is installed. SafeEnvPath is /bin:/usr/bin. The revision history still shows blanks except the first edit.

Strangely if a new page is created and subsequent changes are saved (within one hour) no error occurs and the command I can see in the apache error log is as follows.

/usr/bin/ci '-mnone' '-t-none' '-d2007/08/16 23:51:33' '-u' '-wTeruYanagihashi' '/home/httpd/twiki/data/Sandbox/TestSave2.txt'

Hope if someone can help me.


TWiki version: TWikiRelease04x01x02
TWiki plugins: DefaultPlugin, EmptyPlugin, InterwikiPlugin
Server OS: ubuntu 6.06
Web server: Apache/2.0.55 (Ubuntu) PHP/5.1.2
Perl version: 5.008007
Client OS: Windows 2000 sp4
Web Browser: Firefox
Categories: Version control

-- TeruYanagihashi - 17 Aug 2007


ALERT! If you answer a question - or someone answered one of your questions - please remember to edit the page and set the status to answered. The status selector is below the edit box.

It looks the problem was the permission on /tmp directory. It was rwxr-xr-x with root user root group. I changed to 777 and it worked. I found this accidentally as I couldn't log in the host with x-windows and the error message said 'permission denied'. A quick search on the net lead to the /tmp directory permission.

-- TeruYanagihashi - 20 Aug 2007

I had this problem in my new 4.1.2 installation. I found that I had forgotten to set the TEMP and HOME paramaters in my Windows server environment (as given in the cookbook). The problem got rectified after I set them and restarted apache

-- ChengappaCB - 22 Dec 2007

Change status to:
Edit | Attach | Watch | Print version | History: r3 < r2 < r1 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r3 - 2007-12-22 - ChengappaCB
  • Learn about TWiki  
  • Download TWiki
This site is powered by the TWiki collaboration platform Powered by Perl Hosted by OICcam.com Ideas, requests, problems regarding TWiki? Send feedback. Ask community in the support forum.
Copyright © 1999-2018 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.