Tags:
create new tag
, view all tags

Question

Hi. Yesterday, I was merrily editing my 4.0.0.-based TWiki. This has been installed for the past few weeks although yesterday was the first time the content was changed. Today, when I log in, it won't authenticate me. So, I remove user authentication. Now, when I edit any topic that existed yesaterday or previous, it responds with:


During save of Main.SiteProblems an error was found by the version control system. Please notify your Community administrator.

=/usr/bin/ci -m%COMMENT|U% -t-none -w%USERNAME|S% -u %FILENAME|F% of /var/www/twiki/data/Main/SiteProblems.txt failed: =


However, refreshing the page shows that the page has actually been updated to include the new edit. If I go in again, and do another edit, I get the following error on save, but this time, the edits are not accepted at all. Appears it will only allow edits once.


During save of Main.SiteProblems an error was found by the version control system. Please notify your Community administrator.

=RCS: /usr/bin/rcs -l %FILENAME|F% failed: =


When I create a new topic, and edit/save them, I get this error: But it will always accept the edit when I refresh the topic.


During save of Main.TestOne an error was found by the version control system. Please notify your Community administrator.

=/usr/bin/ci -m%COMMENT|U% -t-none -w%USERNAME|S% -u %FILENAME|F% of /var/www/twiki/data/Main/TestOne.txt failed: =


Looking in the error log, it showed an error with the UpdateInfoPlugin. So I disabled that, but it still didn't solve the problem. In the error log, I get:


Fri May 05 14:53:05 2006] [error] [client 10.10.21.139] /usr/bin/ci -m%COMMENT|U% -t-none -w%USERNAME|S% -u %FILENAME|F% of /var/www/twiki/data/Main/NewToCommunity.txt failed: at /var/www/twiki/lib/TWiki/Store/RcsWrap.pm line 401., referer: http://x.x.x.x/twiki/bin/edit/Main/NewToCommunity?t=1146837175


So, there are 2 issues .. why has my user authentication suddenly stopped working, and why can't I save changes? Are these 2 problems connected?

As I'm not a Unix-savvy person, nor RCS, can anyone suggest what else to do?

Environment

TWiki version: TWikiRelease04x00x00
TWiki plugins: DefaultPlugin, EmptyPlugin, InterwikiPlugin, Tree, threadedDiscussion, tagme, tagcloud, table, draw, spreadsheet, slideshow, sectionledit, renderlist, preferences, news, imageedittable, comment, childtopictemplate, calendar, approval, alias, actiontracker
Server OS: Linux
Web server: Apache/2.0.52 (White Box)
Perl version: 5.8.5
Client OS: MS Windows XP
Web Browser: Firefox
Categories: Permissions, Authorisation

-- HelenJohnstone - 05 May 2006

Answer

ALERT! If you answer a question - or someone answered one of your questions - please remember to edit the page and set the status to answered. The status selector is below the edit box.

I have no idea what could have happened to your authentication - to few information on that.

The RCS problem could be a rather frequent one on directory ownership: The data/Main/ etc. directories need to be chown ed to the userid under which the web server is running.

Coming to think of it: Maybe your webserver is running under another user id since yesterday? This could explain the authenticatication problem as well if the "new" user id can't read the password file for authentication...

-- HaraldJoerg - 05 May 2006

Have checked the permissions of all files under data, all owned by same userid as the userid under which the server is running. Have also tried unlocking all rcs files. Also, the webserver had not been restarted for a few weeks although I have now restarted it and checked that it is running as the correct user. I've also tried a default install of TWiki 4.0.2 and that has the same problem. Does anyone have any other ideas as to what could be causing this?

-- ChrisSBrown - 08 May 2006

The problem was a full /tmp directory. this caused both the authentication and rcs to fail with misleading error messages.

-- ChrisSBrown - 08 May 2006

I get this same message and it comes and goes based on LDAP authentication installed / not installed. The authentication is working but the RCS is not. I need to dig further and will post my findings.

-- JohnDickJr - 24 Aug 2006

I had this problem in my new 4.1.2 installation. I found that I had forgotten to set the TEMP and HOME paramaters in my Windows server environment (as given in the cookbook). The problem got rectified after I set them and restarted apache

-- ChengappaCB - 22 Dec 2007

I have the same problem, and I have solved it by change the tmp dir as my dir is /tmp/twiki (777) And I've moved it to another directory so it changes the permission to drwxr-xr-x 3 hieult www-data 4096 2008-04-17 15:18 tmp

Change it to 777 and www-data and the problem will be fixed

-- HieuLeTrung - 17 Apr 2008

Edit | Attach | Watch | Print version | History: r6 < r5 < r4 < r3 < r2 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r6 - 2008-04-17 - HieuLeTrung
 
  • Learn about TWiki  
  • Download TWiki
This site is powered by the TWiki collaboration platform Powered by Perl Hosted by OICcam.com Ideas, requests, problems regarding TWiki? Send feedback. Ask community in the support forum.
Copyright © 1999-2015 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.