create new tag
, view all tags
Further to Peter's request for finding unescaped or fully qualified WEB uses I found (using grep):

ManagingTopics.txt:%<nop>METASEARCH{type="topicmoved" web="%WEB%" topic="%TOPIC%" 
NewUserTemplate.txt:   * %WEBPREFSTOPIC% has preferences of the %WIKITOOLNAME%.%WEB% web.
TWikiPreferences.txt:   * %WEBPREFSTOPIC% has preferences of the %WIKITOOLNAME%.%WEB% web.
TWikiVariables.txt:  <td> The current web is <b>%WEB%</b> </td>
TWikiVariables.txt:=%<nop>WEBLIST{"&lt;option $marker value=$qname&gt;$name&lt;/option&gt;" webs="Trash,public" selection="%WEB%" separator=" "}%= Dropdown of all public Webs + Trash Web, current Web highlighted.
WebPreferences.txt:   * List of topics of the %WIKITOOLNAME%.%WEB% web:
WebRss.txt:  <title>%WIKITOOLNAME%'s %WEB% web</title>

which raises:

Q: Does %WIKITOOLNAME%.%WEB% also need to be nop'd? (c.f. the second line, from TWikiPreferences.txt)

Q: And %WEB% within a formatted search construct (c.f. the WEBLIST line from TWikiVariables.txt)

-- MattWilkie - 02 Jul 2004

PeterThoeny, could you please be more specific about what needs to searched for and how it needs to be fixed? I've read your initial post several times, but feel like I am still missing something.

Do you mean to say that every occurence of %WEB% needs to be rewritten to say <nop>Codev ? If yes, then the following pages have been fixed: WebNotify, TextFormattingRules, WebRssBase (twiki web only).

I also updated the documentation in ManagingWebs according to this understanding.

-- MattWilkie - 27 Jul 2004

Thanks Matt for the help smile

Only standalone %WEB% text that potentially could be turned into a link (because of a WikiWord) needs to be escaped. Same for %MAINWEB% and %TWIKIWEB%.


  • %WEB% -- needs to be escaped with <nop>%WEB%
  • (%WEB%) -- needs to be escaped because of parenthesis
  • "%WEB%" -- no need to escape, does not get linked
  • <b>%WEB%</b> -- no need to escape, does not get linked
  • %WEB%.%TOPIC% -- no need, is a Web.TopicName
  • (%WEB%.%TOPIC%) -- no need, is a Web.TopicName

Basically any prefix other then space and parenthesis needs to be looked at. I don't think %WEB% in a SEARCH should be escaped.

Also, the doc sometimes refers to %WIKITOOLNAME%.%WEB% and sometimes simply to %WEB% when refering to webs. I think we should stop using %WIKITOOLNAME% as a web prefix because "Toolname.Web" could be confused with "Web.TopicName". If you find time, could you help to scrap all %WIKITOOLNAME% if prefixed on a web? This needs judgement, sometimes a %WIKITOOLNAME%.%WEB% can be simply shortened to %WEB%, sometimes better to write %WEB% web of %WIKITOOLNAME%

-- PeterThoeny - 28 Jul 2004

checked in fixes for %WEB% and WIKITOOLNAME% (through Develop SVN 4079)

-- WillNorris - 22 Apr 2005

Edit | Attach | Watch | Print version | History: r3 < r2 < r1 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r3 - 2005-04-23 - WillNorris
  • Learn about TWiki  
  • Download TWiki
This site is powered by the TWiki collaboration platform Powered by Perl Hosted by OICcam.com Ideas, requests, problems regarding TWiki? Send feedback. Ask community in the support forum.
Copyright © 1999-2015 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.